Membership Tiers Issue

Incident Report for WHOOP

Resolved

This incident has been resolved.
Posted Oct 28, 2025 - 15:15 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 28, 2025 - 13:25 EDT

Investigating

We’re currently experiencing an issue affecting membership tiers. Our team is investigating and working to resolve it as quickly as possible. Thanks for your patience.
Posted Oct 28, 2025 - 09:02 EDT
This incident affected: Mobile App Features (Core App Features).