WHOOP Coach Outage

Incident Report for WHOOP

Resolved

This incident has been resolved.
Posted Nov 08, 2023 - 14:56 EST

Update

WHOOP Coach is back to operational
Posted Nov 08, 2023 - 11:10 EST

Investigating

WHOOP Coach is unable to answer questions at this time.
Posted Nov 08, 2023 - 10:15 EST
This incident affected: Mobile App Features (WHOOP Coach).