Monthly performance assessments missing for some members
Incident Report for WHOOP
Resolved
This incident has been resolved.
Posted Jul 03, 2020 - 10:25 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 03, 2020 - 08:57 EDT
Update
We are continuing to investigate this issue.
Posted Jul 03, 2020 - 08:28 EDT
Investigating
We are investigating an issue where some members are not able to view or download their June Monthly Performance Assessment. Our engineering team is actively working on a fix. Your data will not be lost and will be caught up shortly.
Posted Jul 03, 2020 - 08:28 EDT
This incident affected: Mobile App Features (Performance Assessments).